[bookmark: _GoBack]An Easy Protocol for FRAP

Alexandre Webster (Aravin Lab, Caltech) and Malte Wachsmuth (EMBL)
February 2014.
This protocol describes how a beginner at microscopy can acquire and analyze Fluorescence Recovery After Photobleaching data using a simplified approach.  Although simplified, this protocol was able to provide a consistent estimate of the mobile fraction of tagged protein expressed in fly ovaries.  We relied on a sample size of 20 to 30 FRAP experiments per specimen, and while obtaining a mean mobile fraction for these experiments was an achievable goal, we were not able to obtain recovery rates or determine the principle components involved in recovery. 
Fluorescence Recovery After Photobleaching (FRAP) is a microscopy approach that utilizes the confocal microscope laser power to bleach a small region of fluorescence signal inside of a biological specimen.  The specimen is imaged periodically post- bleach with significantly reduced laser power to measure the recovery of fluorescence signal at the bleached region.  The extent of fluorescence recovery is a function of protein mobility, as new unbleached protein replenishes bleached proteins.  Calculating the mobile fraction of protein is achieved by measuring the intensity of the bleached region over time.  Pre-bleach images are captured to estimate the pre-bleach intensity and the recovery after bleaching is analyzed relative to this maximal value.  The intensities of two other regions are required for analysis:  The intensity of a reference cell (REF) of fluorescence is required to measure the extent of photobleaching due to image acquisition, in addition to a background (BG) cell that is employed to account for noisy random signals.  These can be selected within the FIJI software (http://fiji.sc/Fiji), as will be described later.
We employ this protocol to investigate the dynamics of proteins localizing to perinuclear RNP granules called ‘nuage’ in Drosophila ovarian germ cells.  These proteins are part of a small RNA defense mechanism that represses the propagation of transposable elements.  We sought to understand the dynamics of two piRNA-interacting PIWI-clade Argonaute proteins—Aubergine (AUB) and Argonaute-3 (AGO3)— in addition to three mutants of each protein.  Each protein is tagged with a GFP fluorophore and over-expressed on a wildtype background using the yeast GAL4-UASP system.  Interestingly, over-expressing the proteins on wildtype background had no effect on their dynamics as measured by FRAP.  We compared the dynamics of one protein, GFP-Aubergine (AUB) over-expressed on a wildtype background to GFP-AUB expressed on an AUB-null background and found the FRAP dynamics of both transgenic proteins were similar regardless of genetic background.  While this was the case for our system, your system might very well be different— always be sure to perform the correct controls!
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Figure 1. GFP-AUB is more mobile than GFP-AGO3:
B) Represenative FRAP experiments of GFP-AUB-WT (grey triangles; high curve) and GFP-AGO3-WT (black diamonds; low curve).  C) Mean percentage of Mobile GFP-AUB-WT and GFP-AGO3-WT taken from 30 and 32 individual FRAP experiments, respectively.  

Materials:
- Microscope:  Zeiss LSM710 with temperature-controlled incubation chamber
- Objective: LD LCI Plan-Apochromat 25x/0.8 Imm Corr DIC M8
- Halocarbon 700 oil for mounting
- Coverslip 40x60mm No.1.5
- Fly station equipped with CO2 and tools for dissecting.  PBS and a dropper.
- FIJI software (http://fiji.sc/Fiji)
Protocol:  
Data Acquisition:
1. Dissect ovaries fresh prior to FRAP experiments.  Flies were anesthetized with CO2 and dissected in PBS and transferred to a small spread of Halocarbon 700 on a glass slide (0.5cm by 1.0cm square).  Ovaries should be sub-dissected so that a) individual ovarioles are spread out and b) so that halocarbon but not PBS surrounds the ovaries.  It is also helpful to ‘pin’ the ovaries to the slide as this will limit the amount of drift that occurs.
2. A 40x60mm No. 1.5 coverslip was placed onto the halocarbon containing ovaries. A timer was started at this point.  The coverslip will begin adhering to the halocarbon and this will cause the ovaries to drift.  Drifting prohibits time-series acquisition, so it is good to wait 6-10 minutes before performing FRAP experiments.  
3. The slide was immediately loaded into the microscope sample holder coverslip-side facing the objective.  Halocarbon 700 is sufficiently viscous to hold the coverslip in place.  Wait 6-10 minutes according to the timer.
4. During this time, use the oculars with DIC enabled to find your specimen.
5. MICROSCOPE settings:
We use Zen (black) software.  The titles refer to default options or modules that can be activated for each experiment.  As a complete novice, it took me 4-6hrs. to optimize the parameters for our needs.  This was important because it is ideal to use the same parameters for all experiments.  Here is what we chose to use:
• Frame Size: 256x256 pixels; 128 resolution.
• Zoom: 10  (pixel size: 0.07µm)
• Scan Speed: 614.4ms  (1.0µs pixel dwell time)
• Laser Power and PMT Gain:  For acquisition, we decided to set the laser power equal for every specimen that we tested, since a variable laser power setting for each specimen could introduce unwanted bias. Some transgenic proteins were more stable than others, so we did have to change the gain control on the microscope for each line we tested.  The laser power we chose was 7.0; Gain was adjusted from about 600 to 850 depending on each line tested.
• Time series: 120 images (each scan represents 0.6144 seconds elapsed time)
• Bleach: Start Bleach after 5 scans (at least one prebleach acquisition is required for analysis); Select Safe Bleach for GaAsP; Select lasers 488; 561; 633nm.
• Regions: Select a Region Of Interest (ROI) of desired area.  We chose 7x7pixels, as this was a sub-micron bleaching area equal to approximately (0.5µm)2, and could be bleached within the acquisition interval of 614ms, considering the pixel dwell time of 1.0µs. 
• Pinhole: should be set at 1AU.  Other attributes like Digital Offset or Gain were kept at default settings.
• Incubation:  between 20-25°C.  
5. Once the ovaries have settled from drifting, FRAP experiments can now be performed.  Find an egg chamber that is of mid-stage expression, refine the focal plane so that a given nurse cell nucleus is at its widest and define a 7x7 pixel Bleach ROI around a nuage granule.  IMPORTANT:  It is important to include in your frame a region that can be used for background.  This is a region outside of your fluorescent tissue that consists of only noise. 
6. Start Experiment.  Time course should take about 70 sec.  Save data in ‘LSM5’ format, since this can be imported easily into FIJI (FIJI Is Just Imagej— see link in introduction).  A consistent file title format is important, considering many samples will be acquired over several sessions.  I chose to use Date_FlylineID_Experiment#  (something like 122513_294_001; with 294 coding for the GFP-AUB-WT line).
7. Continue acquisition of FRAP experiments for up to one hour conservatively.  Although dynamics of nuage proteins do not appear to be affected by oogenesis stage or whether the ovaries have been dissected within the past two hours, it is best to maintain a ‘representative’ fresh tissue specimen— stop acquiring frap before 1hr post dissection.  The rate of acquisition should be about 10 FRAP experiments per half hour.
8. Transfer .lsm files to personal computer for analysis. Download FIJI software: (http://fiji.sc/Fiji)

Data Analysis:
9. Keeping data organized.  I organized my data in an excel file with the first spreadsheet as a summary of each experiment.  Each line was called by its file name e.g. ‘122513_294_001.’ Then, each subsequent sheet of the file was dedicated to calculating the mobile fraction of the experiment.  This was important for easy data management.
10. Open the .lsm file with imagej— this should occur when you double click the file.  Otherwise, try importing by File > Import > Image sequence, then select one image (first one), then in the next dialog, select the files to be imported.
11. Open ROI manager by going to Analyze > Tools > ROI Manager.
12. Draw a box around bleach zone with the square tool.  In ROI Manager, click Add[t] button to preserve the region of interest (ROI).  It is helpful to rename each ROI to identify what region it represents.  For Bleach ROI, the dimensions of the box should equal the size of the bleach region used during microscopy.  Our bleach zone was 7x7px with each pixel equaling 0.07µm, i.e., (0.49µm)2.  For other regions, the box dimensions can be arbitrary, but be sure to retain the same measured area for all experiments analyzed.  If you experience DRIFT see note in trouble-shooting.
13. Once the bleach zone is defined, acquire data points for the ROI over the entire time series.  In ROI Manager, click the MORE>> button and select MultiMeasure.
• Make sure boxes [ ] Measure All Slices and [ ] One Row Per Slice are selected.
• Press OK.
* To change the type of data being extracted from the ROI, go to Analyze > Set measure.  Here, all types of data that can be extracted from the ROI are listed.  Only the Mean Gray Value is critical.  	
14. The output will be in a list format that can be copied and pasted into Excel.  Each region to receive its own column.
15. Extract data for all Regions of Interest.  These include:
	BL:  BLEACH :  The exact region bleached by the laser.
	BG:  BACKGROUND:  A Region of only noise 
             (outside of any target fluorescence)
REF: REFERENCE: A Region of Fluorescence outside of the bleached region.  This is used to show bleaching from repeated imaging as a result of the time lapse.
[optional]
TOT: TOTAL: The total intensity from the entire imaged zone can be substituted for the REF region if your specimen requires so.  Remember that the TOT region will also encompass the bleach region, so this might affect corrections— I did not try using TOT for correction.
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Figure 2. Regions of Interest saved in ROI Manager controller:
BL:  Bleach region that will test for recovery
BG:  Background region used to correct for noise
REF:  Reference region to show decay of fluorescence resulting from acquisition
TOT:  Total signal intensity from the full frame.  Substitutes for REF.
9. In Excel, paste the mean intensity values for each ROI into individual columns.  There should be three ROIs in total:  BL, BG, and REF (or TOT).  When plotted together, they should look similar to this example:
 

10. Subtract Background (BG) values from Bleach (BL) and Reference (REF) to obtain corrected values (corr1).  This eliminates noisy signal from the data.
BL_corr1(t) = BL(t) – BG(t)
REF_corr1(t) = REF(t) – BG(t)
11.  Normalize corrected Bleach to corrected Reference.
	BL_corr2(t) = BL_corr1(t) / REF_corr1(t) = [BL(t) – BG(t)] / [REF(t)-BG(t)]
The goal here is to remove any unwanted yet unavoidable photo-bleaching during the post-bleach/recovery sequence and to estimate to what extent the signal recovers with respect to the pre-bleach intensity. Here we have to distinguish two cases: (i) when you do not remove a significant fraction of the overall fluorescence during your bleach step, the fluorescence can potentially recover to the actual pre-bleach value and you should normalize to REF. Any deviation from the pre-bleach intensity for the final post bleach intensity is biologically induced, e.g. by fully immobilized molecules that cannot be replaced by fluorescent ones; (ii) when you bleach a significant fraction of the overall fluorescence, e.g. when bleaching half a nucleus, upon full equilibration the maximum recovery is less than 100% with respect to the pre-bleach intensity. In order to account for this, one can normalize to TOT, which represents the fully available fluorescence. However, this is an approximation because especially in a confocal microscope one gets only a thin section of the sample and not the full cell volume.  The data should now appear similar to this:



12. Normalize to the mean pre-bleach intensity.  The mean pre-bleach value represents the maximum intensity to which the bleached region could possibly recover.  In our settings, we obtain five pre-bleach frames, but more pre-bleach frames can be obtained, if desired.  We wanted to limit the amount of bleaching we caused by acquisition, but also desired a large enough set of pre-bleach intensities to obtain a reliable mean.  The mean pre-bleach intensity is used to normalize the corrected bleach value, BL_corr2.  
BL_corr3(t) = BL_corr2(t) / BL_corr2(pre-bleach)
It is not necessary to set the first post-bleach value to zero. The reasons for the incomplete bleaching are at least two-fold: (i) it is not possible to bleach away all molecules due to insufficient laser power; (ii) an initial diffusional contribution is so fast that you cannot resolve it and a decent fraction has already recovered when acquiring the first post-bleach frame. When acquiring the FRAP sequence, you should make sure that you use all available laser power (also from other lines, 458 nm, 488 nm, 514 nm etc.), and you can increase the number of bleach frames at the expense of time resolution. If increasing both laser power and number of bleach frames does not affect the first post-bleach intensity, the remaining signal is most likely due to fast initial diffusional recovery.  The data now appears within the ranges of 1 and 0, or 100% signal intensity and 0% signal intensity.  We see that the curve takes on an exponential recovery-like shape and plateaus at approximately 60% recovery:



13. Many techniques are available to model a fit of data.  We use the Curve Fitting function in FIJI.  This is accessible in Analyze > Tools > Curve Fitting…
In the popup window, delete the content of the data area and copy only the post-bleach section of the normalized recovery curve.  Select “Exponential Recovery” from the dropdown menu and press the “Fit” button:  





Formula: y=a•(1-exp(-b•x)) + c
…
Sum of residuals squared: 0.3823
Standard deviation: 0.0579
R^2: 0.6001
Parameters:
  a = 0.2990
  b = 0.0471
  c = 0.3280
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The the fit parameters are as follows:
Complete recovery would mean a+c=1.  Thus, the fraction of immobile protein,
f_immo = 1 – a – c 
or
f_mobile = a + c

a is a slowly recovering fraction.
c is a rapidly diffusion fraction.
b is the recovery rate, and when assuming uncoupled diffusion and binding, this corresponds to k_off = b

In this example, f_mobile = a + c = 0.2990 + 0.3280 = 0.627, or 62.7% mobile protein

Independent of this more mechanistic interpretation, you can always use f_immo and b to characterize and distinguish mutants, different treatments, etc.  For this protocol, we found the most consistent approach was to simply determine the mobile fraction:
f_mobile = a + c

Calculations of rate value, b, were inconsistent between replica FRAP experiments.  Also, while the sum of fast and slow mobile fractions, a and c, were consistent, the individual values of a and c fluctuated and were alone inconsistent.  Below is the finalized representative FRAP recovery curve for one experiment:



We next repeated this process for 20 to 30 replicates for each line and obtained a mean f_mobile value, which was interpreted as a measure of mobility within granules.  The same analysis was performed for both GFP-AUB and GFP-AGO3, as shown in figure 1.  We also observed 20% decrease in mobility for some of the mutant transgenic proteins analyzed (data not shown).  As expected, other mutant lines showed no change in mobility.

Trouble-shooting:
Drift 
Drift can be corrected in some cases using FIJI using the Registration Plug-in (http://fiji.sc/StackReg).  If drift cannot be corrected, the experiment must be rejected.  Go to PlugIn > Registration > Stack Reg.  In the pop-up window, several corrective transformations are available:  Translation, Rigid Body, Scaled Rotation and Affine.  Each corrects a particular type of drift based on different models. It is sometimes helpful to correct with Translation model then correct again with Rigid body model:  
1. Translation. The mapping of coordinates takes the form x = u + Δu. There, the input coordinate u is mapped to the output coordinate x, and the constant vector Δu gives the amount of translation.
2. Rigid Body. The mapping of coordinates takes the form x = { {cos θ, −sin θ}, {sin θ, cos θ} } ⋅ u + Δu. Because of the presence of the term Δu, translation is considered too, in addition to the rotation by an angle θ.
3. Scaled rotation. The mapping of coordinates takes the form x = λ { {cos θ, −sin θ}, {sin θ, cos θ} } ⋅ u + Δu. The difference with respect to a rigid-body transformation is the presence of the scalar resizing factor λ.
4. Affine. The mapping of coordinates takes the form x = { {a11, a12}, {a21, a22} } ⋅ u + Δu. As the four coefficients a11, a12, a21, and a22 are independent, an affine transformation has even more degrees of freedom than a scaled rotation.

Taken from http://bigwww.epfl.ch/thevenaz/stackreg/

Bleaching during acquisition
Some ovaries that express low levels of fluorophore-tagged protein will bleach rapidly during acquisition. The result is an anomalous exponential recovery model.  Sometimes repositioning the REF region to a bright region that is less prone to bleaching can prevent the anomaly.  Sometimes problems analyzing recovery were unsolvable and these experiments were discarded.  It is still not clear to me why these errors occur, but the data cannot be salvaged.  

Variability between replicates
We found large differences exist between replicate FRAP experiments.  We tried to mitigate this variability by averaging over many experiments.  We aimed to have 20 to 30 replicas per line, which made the mean mobile fraction value more reliable.  We indicated variability in our analysis using standard error calculations of the replicate experiments, but standard deviation also provides this information.
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